Page 7 of 7

Re: Xboard 4.5.X Installer for Mac OSX

PostPosted: 09 Jan 2012, 04:52
by Josh Pettus
Ok reuploaded, the permissions thing should be fixed, and included another executable .command file for VICS.

Re: Xboard 4.5.X Installer for Mac OSX

PostPosted: 27 Jan 2012, 09:53
by H.G.Muller
It seems there still is a problem with a stray character in the xboard.conf file, see a bug report at

http://www.talkchess.com/forum/viewtopi ... 4&start=12

Re: Xboard 4.5.X Installer for Mac OSX

PostPosted: 28 Jan 2012, 18:31
by Josh Pettus
Oops!
Thanks, and fixed! I hope..

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 27 Jul 2012, 13:57
by Josh Pettus
Hi all, sorry it has been for ever since I updated the main package. But it is here now, and hopefully it works. If not let me know, ofc. Personally, I was hoping for that xboard native mac project to pan out, but I guess he disappeared too. :\

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 29 Jul 2012, 03:20
by matematiko
Darklord42 wrote:Hi all, sorry it has been for ever since I updated the main package. But it is here now, and hopefully it works. If not let me know, ofc. Personally, I was hoping for that xboard native mac project to pan out, but I guess he disappeared too. :\


I am not a MAC user bud, but I am sure your efforts are well noted.

Thanks for this, how is the music thing going?

Best regards,

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 30 Jul 2012, 03:29
by Josh Pettus
Thanks mate! it goes well. :)

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 14 Apr 2013, 11:13
by cavendish
Great!

Could you share how did you build it? Maybe others could follow to build the latest version. Thanks.

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 15 Apr 2013, 12:16
by Josh Pettus
Unfortunately with the requirement of cairo, and several hundred dependencies needed for it, in 4.7, this method is no longer practical. Not to mention such dependencies are impossible for me to compile for other than my own system. I use macports to sort it all out, but it will only install versions for the system you are using. I suppose one could include the libraries, several hundred megabytes, but they would be set up in the macports way and that would just conflict with those who use macports. It's just a nightmare. What needs to be done is for someone to update xboard 4.7 package on macports so people can install it through there. It also allows for one to select whether they want xaw or gtk versions. Or a apple package application if someone can make a librsvg.framework. I just don't know where to get started for either.

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 16 Apr 2013, 15:35
by cavendish
Thanks for the information.

I am a brew user, I tried xboard there, it's only 4.6 now, and it reports missing "fairymax" when launch. I will have a try to upgrade it to 4.7 later. Could you give me some suggestion for fairymax? Thanks in advance.

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 16 Apr 2013, 18:35
by H.G.Muller
The Fairy-Max engine is available as Debian package and from the Ubuntu repositories. I don't know if your distribution can install such packages. If not, you could try to install from source. Which can be found in my on-line repository http://hgm.nubati.net/cgi-bin/gitweb.cgi , from where you can load the latest 'snapshot' as tar ball. It contains a simple make file, so you can run "sudo make install" from the directory where you unpacked the tar ball right away.

Of course you could run XBoard even without Fairy-max installed by specifying an engine you do have installed (e.g. "xboard -fcp crafty" or "xboard -fcp fruit -fUCI"). Or using it in -ics or -ncp mode, which does not require an engine.

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 16 Apr 2013, 19:40
by cavendish
brew builds 4.7.0 ok. My pull request is in https://github.com/Homebrew/homebrew-games/pull/50

But still missing "fairymax".

OK, got fairymax built and running on my machine. My current steps:
1. get source from http://hgm.nubati.net/fairymax.tar.gz
2. decompress and run "make" in it, copy the fairymax binary file to PATH, for example /usr/bin for now.
3. sudo mkdir -p /usr/share/games/fairymax && sudo cp ~/Downloads/Fairy-Max/data/* /usr/share/games/fairymax

Then xboard works fine. Will have a look more to get fairymax included by brew.

Re: Xboard 4.6.X Installer for Mac OSX

PostPosted: 26 Apr 2013, 20:39
by cavendish
homebrew(brew) could install xboard 4.7.0 and fairymax 4.8S now. But hey are built from source, you need to have compiler on your machine. Maybe brew could provide bottle(pre-build) releases in the future.)