WinBoard & Chessclub.com

Discussions about the WinBoard protocol. Here you can also report bugs and request new features.

Moderators: hgm, Andres Valverde

WinBoard & Chessclub.com

Postby Thomas Mayer » 25 Jan 2010, 09:33

Hi,

I don't know wether this problem exists as well on FICS but it annoys me since several years and I wonder if there could be a solution for it.
Usually my engine plays fully automated on ICC, additionally I have a weakened version of Quark running on ICC - just to entertain the members there. My home network is connected to the internet via DSL and a router which is automatically disconnected about every 24 hours by my ISP and there is nothing I can do against this. The problem is now, that WinBoard doesn't recognize the disconnection and does not reconnect itself to ICC so that I always have a) an aborted or adjourned game and b) hangs around for several hours doing nothing until I reconnect it. A possible solution could be something like: "If you don't hear anything from the ICS for x minutes, disconnect and try to reconnect" - Would that be possible, Harm ?

Greetings, Thomas
User avatar
Thomas Mayer
 
Posts: 40
Joined: 26 Oct 2004, 13:45
Location: Germany

Re: WinBoard & Chessclub.com

Postby H.G.Muller » 25 Jan 2010, 10:50

Incredible: the other day John Dart reported exactly the same problem for XBoard on CCC.

In response I enhanced the -keepAlive option to not only periodically send a 'date' command to the ICS periodically, but have it actually look if there is a response. If the previous date command was not answered by the time the next comes up, it assumes the connection is ded, and makes a fatal error exit. The whole thing is completely untested, of course; I have no idea how i could test it. But if this happens to you daily, perhaps you could run a debug file, to make sure it worked, or diagnose the problem if it didn't.

A WinBoard binary that has this feature is currently at http://hgm.nubati.net/winboard.zip .
User avatar
H.G.Muller
 
Posts: 3220
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: WinBoard & Chessclub.com

Postby Thomas Mayer » 25 Jan 2010, 17:43

H.G.Muller wrote:Incredible: the other day John Dart reported exactly the same problem for XBoard on CCC.

In response I enhanced the -keepAlive option to not only periodically send a 'date' command to the ICS periodically, but have it actually look if there is a response. If the previous date command was not answered by the time the next comes up, it assumes the connection is ded, and makes a fatal error exit. The whole thing is completely untested, of course; I have no idea how i could test it. But if this happens to you daily, perhaps you could run a debug file, to make sure it worked, or diagnose the problem if it didn't.

A WinBoard binary that has this feature is currently at http://hgm.nubati.net/winboard.zip .


Hi Harm,

thanks ! I will give that a try over night. If the engine is still on tomorrow morning the problem is solved, I will inform you.

Greetings, Thomas
User avatar
Thomas Mayer
 
Posts: 40
Joined: 26 Oct 2004, 13:45
Location: Germany

Re: WinBoard & Chessclub.com

Postby Thomas Mayer » 26 Jan 2010, 09:47

Hi Harm,

works like a charm ! Will you include this in future releases of WinBoard ? Else I will keep this particular version for online play.

Greets, Thomas

P.S.: Of course I will let it run for some more nights
User avatar
Thomas Mayer
 
Posts: 40
Joined: 26 Oct 2004, 13:45
Location: Germany

Re: WinBoard & Chessclub.com

Postby H.G.Muller » 26 Jan 2010, 10:41

It will certainly find its way intu future versions of WinBoard. But the question is which one. We now have a policy to not add new features to the current stabl version (the 4.4.x series) and only do bug-fixes. So what you have now is the development version (4.2010xxxx).

But as this seems a quite innocent enhancement of an already-existing opton (-keepAlive), that hardly involved any code change (just adding a flag that is set on any input), we could declare this a 'bugfix', an put it in 4.4.3. :D
User avatar
H.G.Muller
 
Posts: 3220
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: WinBoard & Chessclub.com

Postby Thomas Mayer » 29 Jan 2010, 16:41

Hi Harm,

it runs now smootly since 4 nights and I had a disconnection every night and it did reconnect always within 5-10 minutes (-keepAlive 5). For me that's a perfect solution, thank you !

Greets, Thomas

P.S.: Clearly it's a bugfix... ;)
User avatar
Thomas Mayer
 
Posts: 40
Joined: 26 Oct 2004, 13:45
Location: Germany


Return to WinBoard development and bugfixing

Who is online

Users browsing this forum: No registered users and 3 guests