ICS Interaction Context Menu behaving differently

Discussions about the WinBoard protocol. Here you can also report bugs and request new features.

Moderators: hgm, Andres Valverde

ICS Interaction Context Menu behaving differently

Postby EdCollins » 12 May 2011, 05:26

Greetings,

In version 4.5.2, I noticed the ICS Interaction Context Menu operates slightly differently.

In older versions of WinBoard (4.4.2, for example... I just tested it with this old version) while connected to an ICS server, a single right-click brought up the context menu and that menu stayed on the screen. The user could then chose (highlight) the option they wanted and left-click it to execute it.

But now, in 4.5.2 version, a single right-click brings up the context menu for just a brief second. The command that happens to be in the the upper right corner is then executed, and then the context menu just as quickly, disappears! Ouch!

In order for me to use the menu, I have to right-click and hold the right-mouse button down, and continue to hold it down while then moving the mouse to the desired action, and then letting go of the right mouse button.

This method/procedure doesn't seen nearly as intuitive or natural to me. (And it's also much slower, as I must be careful to not let go of the right mouse button too early. If I do, an unwanted command, whatever happens to be highlighted as I'm moving my mouse, would be executed.)

Was this change intentional and more importantly, is there a winboard ini option (or some other method that I'm not aware of) to give the user the option to change it back to the previous method of selecting an ICS command?

Thanks in advance.

Note: Imagine my initial confusion. I execute a right-click as I've done thousands of times and suddenly I see the menu appear, then disappear, and then the results of an ICS "who" command displayed on the screen! (In the upper-right corner of my personalized context menu, I happen to have the "who" command. I'm glad I didn't have the EXIT command up there.)
EdCollins
 
Posts: 71
Joined: 16 May 2010, 09:05
Location: Southern California

Re: ICS Interaction Context Menu behaving differently

Postby H.G.Muller » 12 May 2011, 07:08

This was intended behavior. People wanted a default command, that could be executed by a single click, in particular to open a chat box. The way to get back the old behavior is to configure an inactive item in the upper-right corner. For this purpose I added the pseudo-command "null". You could define a name of one or more spaces for it in the -icsMenu string, so is shows up as an empty line in the menu.

On Linux, all XBoard menus select on the up-click; this seems to be the standard way for menus in X-applications. Once you got used to it, it is actully faster. To select an item you have to click, and move the mouse to the item anyway. This ust saves you an extra up and down click.
User avatar
H.G.Muller
 
Posts: 3260
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: ICS Interaction Context Menu behaving differently

Postby EdCollins » 12 May 2011, 14:02

Okay, thanks, I'll try that.
EdCollins
 
Posts: 71
Joined: 16 May 2010, 09:05
Location: Southern California


Return to WinBoard development and bugfixing

Who is online

Users browsing this forum: No registered users and 3 guests