Page 1 of 1

hgmmaster/4.6.0 mac compile issues

PostPosted: 02 Nov 2011, 20:05
by Josh Pettus

I tried compiling the hgmaster branch and the 4.6.0cvs build in macOSX and they compiled successfully but I noticed a couple problems within both.

xboard continually spews
Code: Select all
Warning: No type converter registered for '(null)' to 'FontSet' conversion.

this is also perhaps why all font in xboard looks suddenly different in this version.

here are some comparisons.

xboard hgmaster/4.6.0cvs

xboard 4.5.3

You will also notice that for some reason when a second engine is started the second engines clock always reverts to the maximum time possible to input in xboard. This is for both classical and incremental modes.

Of course none of this happens in Ubuntu.

Re: hgmmaster/4.6.0 mac bugs

PostPosted: 03 Nov 2011, 20:52
by NaltaP312

i will be interested to know how you have compiled xboard for mac
I use the installer 4.5.3 for mac to play with it
i have compile Danasah 4.24 and the life is better ;)


Re: hgmmaster/4.6.0 mac bugs

PostPosted: 07 Jan 2012, 23:58
by H.G.Muller
The clock problem should be solved in the latest version. The font stuff is a bit beyond my expertise.

Re: hgmmaster/4.6.0 mac bugs

PostPosted: 08 Jan 2012, 01:57
by Josh Pettus
Yah I noticed, that's good. Thanks! For some reason now, the font stuff doesn't keep repeating and flooding the terminal. So now its become a very minor problem.

Re: hgmmaster/4.6.0 mac bugs

PostPosted: 08 Jan 2012, 18:00
by Josh Pettus
I noticed a new bug, when typing in terminal to launch a wb engine. eg
"xboard -fcp crafty"

-fUCI is automatically invoked causing the engine to fail with "not a UCI engine."

Re: hgmmaster/4.6.0 mac bugs

PostPosted: 28 Jan 2012, 09:00
by H.G.Muller
Oh, I must have missed this post.

This can only be because you configured it wrong (i.e. have a -fUCI in the xboard.conf master settings file).

Re: hgmmaster/4.6.0 mac bugs

PostPosted: 28 Jan 2012, 18:32
by Josh Pettus
Yah must have been, it has been since overwritten with another installer and is now working. Thank-you though

Re: hgmmaster/4.6.0 mac bugs

PostPosted: 30 Jul 2012, 03:35
by Josh Pettus
New issue when compiling on 10.8 it cant find the Intrinsic.h header for some reason. Its in the place it should be /usr/X11/include/X11 but for some reason it's not finding it
could this be a permissions issue?

never mind, the more i look into it the more it appears to be an OS 10.8 issue. what a pain... still havn't figured it out

Apperently I have to set the correct path to the compiler for X11. What a pain that apple no longer ships with X11 and I must jump through these hoops.
Xcode doesn't even include automake anymore and had to install that via mac ports

Code: Select all
export CPPFLAGS=-I/opt/X11/include

Re: hgmmaster/4.6.0 mac compile issues

PostPosted: 04 Oct 2012, 06:00
by Josh Pettus
I've been trying to compile the master branch for a while now, but for some reason it fails because ./configure doesn't detect NLS which I take is part of the gettext.
which I have.

Code: Select all
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for library containing strerror... none required
checking whether NLS is requested... yes
checking for msgfmt... /opt/local/bin/msgfmt
checking for gmsgfmt... /opt/local/bin/msgfmt
checking for xgettext... /opt/local/bin/xgettext
checking for msgmerge... /opt/local/bin/msgmerge
checking build system type... x86_64-apple-darwin12.2.0
checking host system type... x86_64-apple-darwin12.2.0
checking for ld used by GCC... /usr/llvm-gcc-4.2/libexec/gcc/i686-apple-darwin11/4.2.1/ld
checking if the linker (/usr/llvm-gcc-4.2/libexec/gcc/i686-apple-darwin11/4.2.1/ld) is GNU ld... no
checking for shared library run path origin... done
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for CFPreferencesCopyAppValue... yes
checking for CFLocaleCopyCurrent... yes
checking for GNU gettext in libc... no
checking for iconv... yes
checking for working iconv... yes
checking how to link with libiconv... -liconv
checking for GNU gettext in libintl... no
checking whether to use NLS... no
checking for remsh... no
checking for rsh... rsh
checking for makeinfo... makeinfo
checking for nroff... nroff -man
checking for awk... /usr/bin/awk
checking for perl... /opt/local/bin/perl
checking for ANSI C header files... yes
checking whether time.h and sys/time.h may both be included... yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking return type of signal handlers... void
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking stropts.h usability... no
checking stropts.h presence... no
checking for stropts.h... no
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for string.h... (cached) yes
checking for unistd.h... (cached) yes
checking sys/systeminfo.h usability... no
checking sys/systeminfo.h presence... no
checking for sys/systeminfo.h... no
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking stddef.h usability... yes
checking stddef.h presence... yes
checking for stddef.h... yes
checking for _getpty... no
checking for grantpt... yes
checking for setitimer... yes
checking for usleep... yes
checking for gettimeofday... yes
checking for random... yes
checking for gethostname... yes
checking for setlocale... yes
checking for getpseudotty in -lseq... no
checking whether compiler understands -Wall -Wno-parentheses... yes
checking for X... libraries /usr/X11/lib, headers
checking whether -R must be followed by a space... no
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking X11/Intrinsic.h usability... yes
checking X11/Intrinsic.h presence... yes
checking for X11/Intrinsic.h... yes
checking X11/Xaw/Dialog.h usability... yes
checking X11/Xaw/Dialog.h presence... yes
checking for X11/Xaw/Dialog.h... yes
checking X11/xpm.h usability... yes
checking X11/xpm.h presence... yes
checking for X11/xpm.h... yes
checking for XpmReadFileToPixmap in -lXpm... yes
checking whether ptys or pipes should be used... pipes
checking for xdg-mime... no
checking for xdg-desktop-menu... no
checking for xdg-icon-resource... no
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating cmail
config.status: creating po/
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing po-directories commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
config.status: executing test-stamp-h commands
config.status: executing chmod-cmail commands

 Configurations summary:

        prefix:          /usr/local       
        datarootdir:     ${prefix}/share 
        datadir:         ${datarootdir}   (icons will go in $datadir/icons/hicolor/...)
                                    (bitmaps will go in $datadir/games/xboard/...)
        infodir:         ${datarootdir}/info   (info files will go here)
        sysconfdir:      ${prefix}/etc   (xboard.conf will go here)

        update mimedb:   yes

        NLS support:     no

        Xaw3d:           no

        xpm:             yes
        ptys:            pipes
        zippy:           yes
        sigint:          yes


Code: Select all
make  all-recursive
Making all in po
  CC       backend.o
  CC       book.o
  CC       childio.o
  CC       gamelist.o
  CC       ngamelist.o
  CC       lists.o
  CC       moves.o
  CC       parser.o
  CC       pgntags.o
  CC       uci.o
  CC       xboard.o
xboard.c: In function ‘InitializeFonts’:
xboard.c:1108: warning: unused variable ‘vTo’
xboard.c: In function ‘main’:
xboard.c:1457: error: ‘clockFonStruct’ undeclared (first use in this function)
xboard.c:1457: error: (Each undeclared identifier is reported only once
xboard.c:1457: error: for each function it appears in.)
make[2]: *** [xboard.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Disabling NLS doesn't seem to fix it as some things in the code appear to require it. What else do I need to pass the NLS check?

{edit} changed thread title as it stopped being about a bugs a long time ago :)

Re: hgmmaster/4.6.0 mac compile issues

PostPosted: 05 Oct 2012, 04:54
by Josh Pettus
I really don't get it as you can see i have msgfmt, gmsgfmt, xgettext, and msgmerge. is it the not finding gettext in libc and libintl? why would it not be in there? how do i get it in there?

Re: hgmmaster/4.6.0 mac compile issues

PostPosted: 05 Oct 2012, 06:19
by Josh Pettus
Well forgetting that NLS fails to enable, i guess the bug is that variable is suppose to be "clockFontStruct" not "clockFonStruct" on line 1457

When i changed that Xboard.c compiles but then i get a new error on xoptions.c

Code: Select all
xoptions.c: In function ‘GenericPopUp’:
xoptions.c:886: error: aggregate value used where an integer was expected
make[2]: *** [xoptions.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

looks to be an issue with the compiler included with the new xcode...:(

this is master-20120930