Odd output in ICS console

Discussions about the WinBoard protocol. Here you can also report bugs and request new features.

Moderators: hgm, Andres Valverde

Odd output in ICS console

Postby damo » 21 May 2014, 03:32

Hello,

I am currently using WinBoard 4.7.3a and the engine Stockfish 170514 (64-bit). I am wondering why I see a number output to the FICS console every time the engine makes a move. For instance, it will begin with the number "1" and this will be repeated each move for about 10 moves. Unpredictably, it will change to the number "2" for a while and then "3" and so on. Sometimes, it will only print the number "1", though. Below is an example of what I see in the console after some moves (including moves by the book controlled by WinBoard):

1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 3 3 3 3 3 3 3 3 3 3 3 3

I noticed that it does not do this when I am running the engine Sjeng 11.2 on FICS. This issue is not a real problem for me, but I find it curious and somewhat annoying.

If anyone can help me stop this behavior, I would very much appreciate it.

Thank you,

damo
damo
 
Posts: 2
Joined: 17 May 2014, 21:57

Re: Odd output in ICS console

Postby H.G.Muller » 21 May 2014, 06:38

This is the number of listeners to the engine's kibitz messages. The ICS will reply to those with someting like '(told 3)' on a separate line, plus a new prompt. But to make it less verbose, WinBoard only keeps the number.

You can stop it by switching off auto-kibitz.
User avatar
H.G.Muller
 
Posts: 3080
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Odd output in ICS console

Postby damo » 21 May 2014, 20:27

Ahh, thank you for clarifying that for me!
damo
 
Posts: 2
Joined: 17 May 2014, 21:57


Return to WinBoard development and bugfixing

Who is online

Users browsing this forum: No registered users and 1 guest