No value provided for argument -firstChessProgram

Discussions about the WinBoard protocol. Here you can also report bugs and request new features.

Moderators: hgm, Andres Valverde

No value provided for argument -firstChessProgram

Postby Zonuli » 18 Aug 2015, 22:08

Hi,

After updating FreeBSD from 9.2 to 10.2, xboard exits with an error:

> xboard -fcp crafty
> xboard: No value provided for argument -firstChessProgram

This happens regardless of whether xboard is installed from the package or compiled from the sources.

The same error appears on OpenBSD 5.7.

Xboard works fine on Arch Linux.

Has anyone seen this error? Any idea what causes it?

Thanks.
Zonuli
 
Posts: 1
Joined: 08 Aug 2015, 17:54

Re: No value provided for argument -firstChessProgram

Postby H.G.Muller » 20 Sep 2015, 09:39

Sorry for the late response. I did not answer before because I really had no idea what could be causing this. But as no one else seems to have any ideas either...

This error message is given when XBoard encounters the end of the command line before it encountered a value for the preceding option. So you would expect it on command lines like "xboard -fcp". So at first I thought there should be some mysterious truncation of the command line going on.

However, I notice now that the error message explicitly mentions "-firstChessProgram", for which "fcp" is the shorthand. But XBoard should not be smart enough at the point where this error is geenrated to realize that "fcp" and "firstChessProgram" are the same. If it really complained against a truncated command line "xboard -fcp crafty", it would have said "No value provided for argument -fcp". As it does not do that, it must not be complaining against the command line, but against something it is reading from a settings file. Now -firstChessProgram is a volatile option, so normally it should not be saved the user settings file (~/.xboardrc), unless you edited it into there yourself. But perhaps there is a corruption of your master settings file (/etc/xboard.conf (?)).

This should mean that you would always get that error, however, no matter how you start XBoard. And not only when you do "xboard -fcp crafty"
User avatar
H.G.Muller
 
Posts: 3080
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL


Return to WinBoard development and bugfixing

Who is online

Users browsing this forum: No registered users and 4 guests

cron