Load First Engine exits

Discussions about the WinBoard protocol. Here you can also report bugs and request new features.

Moderators: hgm, Andres Valverde

Load First Engine exits

Postby Brian Richardson » 29 Oct 2018, 19:52

I'm trying the Winboard-AA package (so as not to use Polyglot for UCI), and am having trouble. On Win7Pro, when I click the ... entry to pick a new engine to create in Winboard, it just exits (before the file selector screen appears). I have tried from an administrator cmd (thinking it might be some permission issue) and there is no information. Debug file below. I was able to get one new engine loaded, but I cannot load any new engines anymore. I don't recall exactly what I did such that it worked the one time.
Thanks,
Brian

PS I tried the Edit Engine List option but it throws the changes away. Edit is never highlighted and not clear what Save and OK should do. I am reluctant to edit the wb_engines.dat file

Code: Select all
recognized 'normal' (-1) as variant normal
recognized 'normal' (-1) as variant normal
shuffleOpenings = 0
Version: WinBoard 4.9.182601 + Stockfish
Reset(1, 0) from gameMode 0
recognized 'normal' (-1) as variant normal
GameEnds(0, (null), 2)
shuffleOpenings = 0
StartChildProcess (dir=".") UCI2WB debug "Stockfish.exe" "..\Stockfish"
nice engine proc to 10
608 >first : xboard
protover 2
608 <first : # engine said: Stockfish 301216 by T. Romstad, M. Costalba, J. Kiiski, G. Linscott
608 <first : # 'xboard' think=0 pause=0 log=0 sent=0
608 <first : # 'protover' think=0 pause=0 log=0 sent=0
608 <first : feature setboard=1 usermove=1 debug=1 ping=1 name=1 reuse=0 exclude=1 pause=1 sigint=0 sigterm=0 done=0
608 >first : accepted setboard
608 >first : accepted usermove
608 >first : accepted debug
608 >first : accepted ping
608 >first : accepted name
608 >first : accepted reuse
608 >first : accepted exclude
608 >first : accepted pause
608 >first : accepted sigint
608 >first : accepted sigterm
608 >first : accepted done
608 <first : feature option="UCI2WB debug output -check 1"
608 >first : accepted option
608 <first : uci
608 <first : # engine said: id name Stockfish 301216
608 <first : feature myname="Stockfish 301216 (UCI2WB)"
608 >first : accepted myname
608 <first : # engine said: id author T. Romstad, M. Costalba, J. Kiiski, G. Linscott
608 <first : # engine said:
608 <first : # engine said: option name Debug Log File type string default
608 <first : feature option="Debug Log File -string "
608 >first : accepted option
608 <first : # engine said: option name Contempt type spin default 0 min -100 max 100
608 <first : feature option="Contempt -spin 0 -100 100"
608 >first : accepted option
608 <first : # engine said: option name Threads type spin default 1 min 1 max 128
608 <first : # engine said: option name Hash type spin default 16 min 1 max 2048
608 <first : # engine said: option name Clear Hash type button
608 <first : feature option="Clear Hash -button"
608 >first : accepted option
608 <first : # engine said: option name Ponder type check default false
608 <first : # engine said: option name MultiPV type spin default 1 min 1 max 500
608 <first : feature option="MultiPV -spin 1 1 500"
608 >first : accepted option
608 <first : # engine said: option name Skill Level type spin default 20 min 0 max 20
608 <first : feature option="Skill Level -spin 20 0 20"
608 >first : accepted option
608 <first : # engine said: option name Move Overhead type spin default 30 min 0 max 5000
608 <first : feature option="Move Overhead -spin 30 0 5000"
608 >first : accepted option
608 <first : # engine said: option name Minimum Thinking Time type spin default 20 min 0 max 5000
608 <first : feature option="Minimum Thinking Time -spin 20 0 5000"
608 >first : accepted option
608 <first : # engine said: option name Slow Mover type spin default 89 min 10 max 1000
608 <first : feature option="Slow Mover -spin 89 10 1000"
608 >first : accepted option
608 <first : # engine said: option name nodestime type spin default 0 min 0 max 10000
608 <first : feature option="nodestime -spin 0 0 10000"
608 >first : accepted option
608 <first : # engine said: option name UCI_Chess960 type check default false
608 <first : # engine said: option name UCI_Variant type combo default chess var chess var giveaway var atomic var crazyhouse var horde var kingofthehill var losers var racingkings var threecheck var suicide var loop
608 <first : # engine said: option name SyzygyPath type string default <empty>
608 <first : # engine said: option name SyzygyProbeDepth type spin default 1 min 1 max 100
608 <first : feature option="SyzygyProbeDepth -spin 1 1 100"
608 >first : accepted option
608 <first : # engine said: option name Syzygy50MoveRule type check default true
608 <first : feature option="Syzygy50MoveRule -check 1"
608 >first : accepted option
608 <first : # engine said: option name SyzygyProbeLimit type spin default 6 min 0 max 6
608 <first : feature option="SyzygyProbeLimit -spin 6 0 6"
608 >first : accepted option
608 <first : # engine said: uciok
608 <first : feature oocastle=0
608 >first : accepted oocastle
608 <first : feature variants="normal,giveaway,atomic,crazyhouse,horde,kingofthehill,losers,racingkings,3check,suicide,loop,normal,fischerandom"
608 >first : accepted variants
608 <first : feature egt="syzygy"
608 >first : accepted egt
608 <first : feature smp=1 memory=1 done=1
608 >first : accepted smp
608 >first : accepted memory
608 >first : accepted done
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
608 <first : # 'accepted' think=0 pause=0 log=0 sent=0
624 >first : memory 68
624 >first : egtpath syzygy H:\syzygy
624 >first : cores 1
624 >first : new
random
624 >first : level 0 0:05 2
624 >first : post
624 >first : hard
624 >first : easy
624 >first : ping 1
Impossible move , type = 0
624 <first : # 'memory' think=0 pause=0 log=0 sent=0
624 <first : # 'egtpath' think=0 pause=0 log=0 sent=0
624 <first : # setoption name syzygyPath value H:\syzygy
624 <first : # 'cores' think=0 pause=0 log=0 sent=0
624 <first : # setoption name Threads value 1
640 <first : # 'new' think=0 pause=0 log=0 sent=0
640 <first : # setoption name Hash value 68
640 <first : # setoption name UCI_Variant value chess
640 <first : # isready
640 <first : # engine said: info string Found 510 tablebases
640 <first : # engine said: info string variant chess startpos rnbqkbnr/pppppppp/8/8/8/8/PPPPPPPP/RNBQKBNR w KQkq - 0 1
671 <first : # engine said: info string Found 510 tablebases
671 <first : # engine said: readyok
671 <first : # ucinewgame
671 <first : # 'random' think=0 pause=0 log=0 sent=0
671 <first : # 'level' think=0 pause=0 log=0 sent=0
671 <first : # 'post' think=0 pause=0 log=0 sent=0
671 <first : # 'hard' think=0 pause=0 log=0 sent=0
671 <first : # backlog: setoption name Ponder value true
671 <first : # release 33
671 <first : # 'easy' think=0 pause=0 log=33 sent=33
671 <first : # backlog: setoption name Ponder value false
671 <first : # release 34
671 <first : # 'ping' think=0 pause=0 log=34 sent=34
671 <first : pong 1
702 <first : # engine said: info string Found 510 tablebases
702 <first : 0 0 0 0 Found 510 tablebases
 
                               
                               
                               
                               
                               
                               
                               
                               
                               
                               
                               
                               
                               
                               
                    or specify one below:
Engine (.exe or .jar [______________________________________]
     Engine protocol [ COMBO ]
Nickname (optional): [______________________________________]
[x] Use nickname in PGN tag    [x] Add this engine to the li
[x] Force current variant wit  [x] Must not use GUI book     
command-line paramet [______________________________________]
Special WinBoard opt [______________________________________]
          directory: [______________________________________]
(Directory will be derived from engine pa
Brian Richardson
 
Posts: 37
Joined: 01 Oct 2004, 05:22

Re: Load First Engine exits

Postby H.G.Muller » 30 Oct 2018, 23:05

Hmm, yes, I sometimes have that too. The crash seems to happen inside the file-browse popup, which is in MicroSoft code, not WinBoard code. That is not to blame MicroSoft; it could of course be that I am calling it with invalid parameters, e.g. a pointer that would cause a segfault when it tries to use it. It just means that it is hard to debug with my usual method of putting printf's in the code. I scrutinized the parameters with which I launch the file-browse dialog, and superficially there doesn't seem anything wrong with them.

Strange thing is that it only happens occasionally, and then usually goes away when you use the file browser for another purpose, e.g. load a PGN file.
User avatar
H.G.Muller
 
Posts: 3103
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Load First Engine exits

Postby Brian Richardson » 31 Oct 2018, 11:20

Thanks for the reply.

I just tried starting Winboard-AA and using both File Load Game and Position it exits immediately.

Version 4.7.3a works fine getting to the file selector screen. Perhaps something changed?

Regards,
Brian
Brian Richardson
 
Posts: 37
Joined: 01 Oct 2004, 05:22

Re: Load First Engine exits

Postby H.G.Muller » 31 Oct 2018, 16:27

Well, that is the amazing thing. Nothing was changed in the code relating to this file browsing; it has been there for ages. Suddenly it started doing this, and only on rare occasions. (But once it happens, it is not so easy to make it go away.) Does it also crash when you try to open the browse dialog for saving something?

The Edit-Engine list is a general edit dialog also used for editing tags and book and such. I think it is always in edit mode; that the Edit button is shown is probably a legacy / bug. I think I just forgot to remove it. (Originally there were two 'tags' dialogs, one for editing, and one for just viewing, but the one for viewing contained an Edit button, which would pop it down, and would pop the editable one up. But these dialogs looked identical.)

'Save' commits the changes you made in the text widget to WinBoard's internal settings. This is the same as 'OK', except that the latter also closes the dialog. (Which is fine for editing the engine list, but was very annoying when editing book.) In older WinBoards the engine list was in the regular settings file, and this was only written when you have 'Save Settings on Exit' on. If it was off, (and you don't force saving through 'Save Settings Now'), what you committed to WinBoard internal engine list would not make it to the settings file.

This latest WinBoard can save the engine list in a separate file, but I cannot recall how exactly I implemented this. It would make sense if it wrote that file immediately when you press 'Save' in the edit dialog; one of the reasons to introduce it in the first place must have been to be able to save the engine list without saving other settings.
User avatar
H.G.Muller
 
Posts: 3103
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Load First Engine exits

Postby Brian Richardson » 31 Oct 2018, 17:55

OK, I think I have found at least part of the problem.

I tried doing a Save Position and it exited immediately.

Then, just for whatever, I tried specifying the Just view or edit games option, thinking there might be some delayed problem with the engines already in the Specify Chess Engines 1 and 2 on the first page or in the engines list.

Of course, that works (at least as far as a file selector dialog). But the odd thing, is that loading the first engine in the list worked just fine.
It still does not work without the Just view or edit option.

Brian

Update: Using the Just view option above I was able to add an engine to the list. When restarting and picking that engine, it works. The problem has something to do with the Stockfish V engine that happens to be in the first position in my engine list and is the default in the first page engine 1 and 2 options.
Brian Richardson
 
Posts: 37
Joined: 01 Oct 2004, 05:22


Return to WinBoard development and bugfixing

Who is online

Users browsing this forum: No registered users and 5 guests