Able to log on FICS engine not starting

Discussions about the WinBoard protocol. Here you can also report bugs and request new features.

Moderators: hgm, Andres Valverde

Able to log on FICS engine not starting

Postby Blackdemon » 18 Nov 2019, 20:58

Hello
I have an account on FICS since 1999, i download Winboard 4.8.0, manage to have stockfish working but when i log to FICS and challenge another engine, the other engine start to play but mine is not? I am not too familiar to winboard.
I am out of idea to fixe this can i get help please :?: Thank you
Blackdemon
 
Posts: 8
Joined: 17 Nov 2019, 23:27

Re: Able to log on FICS engine not starting

Postby H.G.Muller » 19 Nov 2019, 12:06

As there are many people that run UCI engines on ICS through WinBoard 4.8.0 all the time without problems, this is unlikely to be due to any problem in WinBoard (or Stockfish), and must thus be cause by the exact way in which you use it. So you should first provide some more information on that before I can say anything sensible.

* How do you start WinBoard? (E.g. did you register Stockfish in the Engine List, and do you select it from the combo-box in the Startup Dialog, or do you type its name there? And what exactly do the various text entries contain when you finally press 'OK' there?)

* If Stockfish can be selected from the Engine List, does it work when you select it and try to play against it locally?

There are many errors that could cause the behavior you describe. E.g. Stockfish might not be installed as a UCI engine, or you might have omitted the option -zp in the start-up command so that WinBoard thinks you want to play a game on FICS yourself.
User avatar
H.G.Muller
 
Posts: 3184
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Able to log on FICS engine not starting

Postby Blackdemon » 19 Nov 2019, 19:31

Hello H.G. muller
First i want to mention that stockfish is working localy on my computer with winboard 4.8.0

my FICS session sequence:
1) i click on winboard.exe
2) From the winboard startup menu i select in the specify chess engines window: i previously edited in the engine list "stockfish_19111420_x64_bmi2.exe" -fd "C:Stockfish" /fUCI -variant normal -ics"
3) i click on use an internet chess server
4) i secify freechess.org /icsport=5000 /icshelper=timeseal
5) I click OK
6) at this point i get the ****** Welcome to the Free Internet Chess Server at freechess.org ******
7) i enter my handle
8) I enter y password
9) I get the welcome menu **** Starting FICS session as Mycomputer engine(C) ****
10) i challenge another chess engine
11) The game starts
12) the other engine starts and plays the first move if it has white, but my engine stockfish wont play
Blackdemon
 
Posts: 8
Joined: 17 Nov 2019, 23:27

Re: Able to log on FICS engine not starting

Postby H.G.Muller » 20 Nov 2019, 09:23

OK, I see. The problem is that ticking the "Use an ICS" button primes WinBoard for using the ICS as a human player. It grays out the engine-selection combo-boxes because it will ignore their setting entirely, even when you changed it before the "Use an ICS" radiobutton was ticked.

Unfortunately there is no radiobutton in the Startup Dialog for selecting ICS engine play (the so-called "Zippy mode"), in which both the ICS and (first-)engine combobox are enabled. Which means you have to put in the options required for one of the two by hand (e.g. in the 'Additional options' field). And you should include a -zp option too. What should work is keep "Play against a chess engine" ticked, and as additional options add:

-zp -ics -icshost freechess.org -icshelper timeseal

Which, btw, is the same as

/zp /ics /icshost=freechess.org /icshelper=timeseal

(One is Linux style, the other Windows style for options, but WinBoard understands both.) Specifying the port is not necessary, as 5000 is the default.

You can also type these options just behind the options that describe the engine, which were set through the combobox; WinBoard does not care where it encounters its options, as long as it encounters them in a text-entry field that is not being ignored. (Which the engine comboboxes are not, in play-against-engine mode). This allows you to make a special entry in the engine list (e.g. through the Engine -> Edit Engine List menu) for Stockfish that already contains these options appended to the normal ones. Then you can just select that entry from the combobox (in play-against-engine mode), and press OK, whenever you want to run Stockfish on FICS.
User avatar
H.G.Muller
 
Posts: 3184
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Able to log on FICS engine not starting

Postby Blackdemon » 20 Nov 2019, 15:47

Thank you very much H.G.Muller it is working finally. One more thing, i managed to have stockfish to use the book.bin but is it possible to indicate to the engine the Syzygy end table?
Best regards
Blackdemon
 
Posts: 8
Joined: 17 Nov 2019, 23:27

Re: Able to log on FICS engine not starting

Postby H.G.Muller » 20 Nov 2019, 19:58

In the Common Engine Options dialog there is a text entry EGTB Path. This can accept a (comma-separated) list of pathnames for folders where the various EGT flavors can be found. Each element in the list must start with the flavor name, then a colon, and then the pathname of the corresponding folder. E.g.

syzygy:F:\EGT\SyZyGy
User avatar
H.G.Muller
 
Posts: 3184
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Able to log on FICS engine not starting

Postby Blackdemon » 20 Nov 2019, 21:33

In this common engine setting was able to save th number of CPU and save on exit, but didn't work for the EGTB i wont retain the path when i re open its gone :shock:
Blackdemon
 
Posts: 8
Joined: 17 Nov 2019, 23:27

Re: Able to log on FICS engine not starting

Postby Blackdemon » 21 Nov 2019, 21:36

Was able to solve my EGTB problem by putting the path without the flavor name and with no colon.
Blackdemon
 
Posts: 8
Joined: 17 Nov 2019, 23:27

Re: Able to log on FICS engine not starting

Postby H.G.Muller » 22 Nov 2019, 15:47

OK, I think I figured this one out. Initially I could not reproduce the problem, but this was because I did not have something in that text entry without a flavor name + colon before.

What happens is this:

Originally only a single flavor of EGT existed: Nalimov. This text entry was then used for setting the WinBoard option -nalimovPath. Later more flavors were developed, and to adopt a future-proof system for indicating those, a new option -egtFormats was defined, which can have arbitrary many flavors with their locations as a comma-separated list. As 'nalimov' could also be specified as a flavor here, the old -nalimovPath option became useless. But for backward-compatibility reasons WinBoard still recognizes it, or otherwise it would choke when it encounters it in the saved-settings file from earlier versions.

This text entry is used for displaying and setting both the -egtFormats and the legacy -nalimovPath option. normally one of the two would be an empty string, depending on whether the user would have switched to the new system already. Then the other one will be displayed. If both are non-empty, though, the -nalimovPath is displayed.

When you write something in the text entry, it will be used as new value for -egtFormats if it contains a flavor name (i.e. a word of more than 1 letter before a colon), and as -nalimovPath otherwise. But the other option will not be changed.

So what probably happened is that you entered something in there without a flavor name, which then was taken as -nalimovPath. When you later entered the syzygy:PATH string, it was used to set -egtFormats (as desired). This was actually saved, and everything should have been working as desired. Except that when you opened the Common Engine dialog the EGTB path entry would keep showing the -nalimovPath, which still had its old (flavorless) value.

So what you entered now, without the flavor name, again went into the -nalimovPath. Which doesn't hurt you, because Stockfish doesn't use Nalimov EGT, so you could put any garbage string there without ill effects. In the mean time the 'eclipsed' value of -egtFormats is still being used for the SyZyGy EGT.

What you can do is simply erase the -nalimovPath by erasing whatever is in the text entry, and OK the dialog. When you then re-open the dialog, it should show the -egtFormats list, which then no longer is eclipsed. Any changes in that (i.e. strings that contain at least one flavor name + colon) should then show up each time when you open the dialog, making it clear they are indeed saved.
User avatar
H.G.Muller
 
Posts: 3184
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Able to log on FICS engine not starting

Postby Blackdemon » 07 Dec 2019, 12:40

Hello,

Concerning the syzygy egtb, finally i found out that the engine is not using it at all ! in the common engine setting, the only way that winboard will keep the EGTB path is by using the 3 little dot ... to conduct winboard to the the proper path and click "OK". if you go back to this menu, winboard saved the path but not able to using it! you cannot type the flavor syzygy: in front of the path manually in this EGTB! box it wont save it. Back to the drawing board :D
Blackdemon
 
Posts: 8
Joined: 17 Nov 2019, 23:27


Return to WinBoard development and bugfixing

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests

cron