Engine xxx has died on me.

Discussions about Winboard/Xboard. News about engines or programs to use with these GUIs (e.g. tournament managers or adapters) belong in this sub forum.

Moderator: Andres Valverde

Engine xxx has died on me.

Postby Gábor Szots » 12 Mar 2017, 09:27

I get that error message with Mediocre, a java engine. I use the latest AA, this did not happen before. What does it mean and what is the cure?

Thanks in advance.
Gábor Szőts

CCRL testing group
User avatar
Gábor Szots
 
Posts: 322
Joined: 26 Sep 2004, 21:26
Location: Szentendre, Hungary

Re: Engine xxx has died on me.

Postby H.G.Muller » 13 Mar 2017, 08:47

This is a message that UCI2WB sends to the GUI for presentation to the user (with the CECP 'tellusererror' command), when an attempt to read from the engine returns an end-of-file condition. (Which is the operating system's way of telling it that no message will ever be coming from it, e.g. because the engine process already exited, or because the engine closed its standard-output channel. Note that in this case the 'engine' is really the Java interpreter.) A similar situation in WinBoard (i.e. when you run the engine directly, without any adapter) would lead to the WinBoard error popup 'engine exited unexpectedly'.

I am not sure how this can be fixed; it seems a Java or Mediocre problem. What exactly is the engine line you used for Mediocre?
User avatar
H.G.Muller
 
Posts: 3066
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Re: Engine xxx has died on me.

Postby Gábor Szots » 13 Mar 2017, 20:15

H.G.Muller wrote:This is a message that UCI2WB sends to the GUI for presentation to the user (with the CECP 'tellusererror' command), when an attempt to read from the engine returns an end-of-file condition. (Which is the operating system's way of telling it that no message will ever be coming from it, e.g. because the engine process already exited, or because the engine closed its standard-output channel. Note that in this case the 'engine' is really the Java interpreter.) A similar situation in WinBoard (i.e. when you run the engine directly, without any adapter) would lead to the WinBoard error popup 'engine exited unexpectedly'.

I am not sure how this can be fixed; it seems a Java or Mediocre problem. What exactly is the engine line you used for Mediocre?


I used a batch file with a single line: java -Xmx1024M -jar mediocre_v0.5.jar

Since then I reinstalled the engine under WB in the regular way, by pointing to the jar file, and later I edited the line in WB.ini to include the -Xmx1024M part. No problem since then.
Gábor Szőts

CCRL testing group
User avatar
Gábor Szots
 
Posts: 322
Joined: 26 Sep 2004, 21:26
Location: Szentendre, Hungary

Re: Engine xxx has died on me.

Postby H.G.Muller » 15 Mar 2017, 00:00

I never used batch files, but I heard that other people sometimes also seem to have trouble with those. It seems that some commands try to get input from the file, rather than from the agent that invoked the file.
User avatar
H.G.Muller
 
Posts: 3066
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL


Return to Winboard and related Topics

Who is online

Users browsing this forum: No registered users and 5 guests