Remote Machine Match

Discussions about Winboard/Xboard. News about engines or programs to use with these GUIs (e.g. tournament managers or adapters) belong in this sub forum.

Moderator: Andres Valverde

Remote Machine Match

Postby Ruben » 20 Jan 2019, 19:53

Hello. I'm trying to get two Windows 10 machines to play each other using uci engines. I set up Windows Remote Management and am able to execute both the local and remote engines using the winrs command on a command prompt. But I can't make a Winboard commandline that actually works. All attempts give me either a "can't find file" or "engine closed unexpectedly" error. Here's the end result of what I've been trying so far:

winboard.exe /cp /mg=1 /fh="" /fcp="winrs -r: -u:xxxxx -p:xxxxx polyglot1.4w.exe andscacs.ini" /sh="" /scp="winrs -r: -u:xxxxx -p:xxxxx polyglot1.4w.exe stockfish.ini" /rsh="winrs" /sgf="..\WinBoard\games\game.txt"
Posts: 3
Joined: 20 Jan 2019, 18:34

Re: Remote Machine Match

Postby Ruben » 22 Jan 2019, 16:21

I changed over to using ssh. When I run the ssh command manually from a command prompt it works just fine. But I try it from WinBoard it just tells me it cant find the file. This is the command I am trying:

WinBoard.exe -debug -cp -fcp="polyglot1.4w.exe andscacs.ini" -fd "../andscacs095" -sh "" -rsh "ssh" -scp "polyglot1.4w.exe stockfish.ini"

Debug Output:

recognized 'normal' (-1) as variant normal
recognized 'normal' (-1) as variant normal
shuffleOpenings = 0
Version: WinBoard 4.8.0b + polyglot1.4w
Reset(1, 0) from gameMode 0
recognized 'normal' (-1) as variant normal
GameEnds(0, (null), 2)
shuffleOpenings = 0
StartChildProcess (dir="../andscacs095") polyglot1.4w.exe andscacs.ini
nice engine proc to 10
829 >first : xboard
protover 2
829 <first : PolyGlot 1.4W29 by Fabien Letouzey
2829 <first : feature done=0
2829 >first : accepted done
2829 <first : feature analyze=1
2829 >first : accepted analyze
2829 <first : feature colors=0
2829 >first : accepted colors
2829 <first : feature draw=1
2829 >first : accepted draw
2829 <first : feature ics=1
2829 >first : accepted ics
2829 <first : feature myname="Andscacs 0.95"
2829 >first : accepted myname
2829 <first : feature name=1
2829 >first : accepted name
2829 <first : feature pause=0
2829 >first : accepted pause
2829 <first : feature ping=1
2829 >first : accepted ping
2829 <first : feature playother=1
2829 >first : accepted playother
2829 <first : feature reuse=1
2829 >first : accepted reuse
2829 <first : feature san=0
2829 >first : accepted san
2829 <first : feature setboard=1
2829 >first : accepted setboard
2829 <first : feature sigint=0
2829 >first : accepted sigint
2829 <first : feature sigterm=0
2829 >first : accepted sigterm
2829 <first : feature time=1
2829 >first : accepted time
2829 <first : feature usermove=1
2829 >first : accepted usermove
2829 <first : feature debug=1
2829 >first : accepted debug
2829 <first : feature variants="normal"
2829 >first : accepted variants
2829 <first : feature done=1
2829 >first : accepted done
2844 >first : new
2844 >first : ics -
2844 >first : level 40 10 0
2844 >first : post
2844 >first : hard
2844 >first : ping 1
Impossible move , type = 0
3094 <first : pong 1
15188 >first : force
StartChildProcess (dir="") ssh polyglot1.4w.exe stockfish.ini
StartChildProcess (dir="") ssh polyglot1.4w.exe stockfish.ini
GameEnds(29, xboard exit, 2)
32798 >first : quit
Process 13264 still alive after timeout, killing... result=1
name = '%APPDATA%\winboard48.ini', expanded name = 'C:\Users\rbenc\AppData\Roaming\winboard48.ini'

All my remote files are in the login directory and I get the same error even with fully qualified paths. I set up ssh keys so I don't need user id or pass.
Posts: 3
Joined: 20 Jan 2019, 18:34

Re: Remote Machine Match

Postby Ruben » 23 Jan 2019, 18:20

All my problems were solved by simply copying the ssh executable into somewhere within my WinBoard directory and the just using the regular chess program command line option. So I just created a "Remote" directory, put ssh in there and then added the following line to the engine list within the gui:

"Remote Stockfish 10" -fcp="ssh polyglot1.4w.exe stockfish.ini" -fd "../Remote"
Posts: 3
Joined: 20 Jan 2019, 18:34

Re: Remote Machine Match

Postby H.G.Muller » 25 Jan 2019, 10:23

I have no experience with this way of running remote engines. The amazing thing is that the command you now give as -fcp (which apparently works) is exactly the same command as WinBoard says it was using in the debug file for the case that did not work.

The difference seems to be that you moved the ssh executable, but if the problem was that WB could not find that, it should have given an error message to that effect when trying to start the engine. So it remains a mystery to me.

I have written my own connection adapter some time ago ('connect.exe'), after unsuccesfully trying to use PuTTY to run a remote engine. (I could find no way to stop it from echoing.) This can act both as a server and a client (depending on the arguments you start it with). On the server side it just needs the engine startup command, and on the client side it needs server IP and port. This made me fully independent from any third-party software, such as ssh servers.
User avatar
Posts: 3222
Joined: 16 Nov 2005, 12:02
Location: Diemen, NL

Return to Winboard and related Topics

Who is online

Users browsing this forum: No registered users and 9 guests